2017年3月13日 星期一

ubuntu16.04安裝gcin

這次,是重灌之後,馬上安裝gcin。
一開始一切順利。
一直到 apt-get upgrade 之後,gcin就開始一直跳錯,一直跳錯。

然後....嗯!再在回想起來有點混亂。
只記得再度跟著原作者的說明,就重裝gcin失敗了。

apt-get使用被gcin套牢


chris@myPC:~$ sudo apt-get install gcin
正在讀取套件清單... 完成
正在重建相依關係 
正在讀取狀態資料... 完成
下列的額外套件將被安裝:
gcin-data gcin-gtk2-immodule gcin-gtk3-immodule gcin-im-client
gcin-qt4-immodule gcin-tables vorbis-tools
建議套件:
gcin-anthy
下列【新】套件將會被安裝:
gcin gcin-data gcin-gtk2-immodule gcin-gtk3-immodule gcin-im-client
gcin-qt4-immodule gcin-tables vorbis-tools
升級 0 個,新安裝 8 個,移除 0 個,有 0 個未被升級。
需要下載 0 B/4,608 kB 的套件檔。
此操作完成之後,會多佔用 19.3 MB 的磁碟空間。
是否繼續進行 [Y/n]? [Y/n] 
【警告】:無法驗證下列套件!
gcin-im-client gcin-data gcin-tables gcin-gtk2-immodule gcin-gtk3-immodule
gcin-qt4-immodule gcin
是否不經驗證就安裝這些套件? [y/N] 
E: 有部份套件無法驗證

然後,就卡住了。 在這個時候,我也不知道要怎麼處理,就跑去問gcin的作者,因為無法打中文,所以用英文寫留言
跑去刪除一個叫staus的文件

/var/lib/dpkg/status

刪除所有關於gcin套件的紀錄。
apt-get就不會被套牢了,不然其它的套件都無法新增或刪除。

可能的解法


後來朋友curt跟我說他以前也有遇到一樣的情況。
gcin一直跳錯的地雷。
他當時是輸入這三行解決的
$ apt-get update
$ apt-get install libappindicator1
$ apt-get install gcin

16.04要怎麼穩穩的裝gcin


後來就跑去安裝15.10版的[2],也就是看原作者的教學,然後把軟體的伺服器路徑改成15.10版的,其它都一樣,就沒問題了。
但是千千萬萬不要刪除ibus,會導致需要重新安裝ubuntu-desktop[3],所以我也重新安裝它了!QQ

隔天的後續

在作者的教學文章後面的發問有了最新的回覆,作者表示16.04經他測試是無誤的。
我覺得太怪了!不過也只能相信作者了!XD
今天就把更新連結改過去16.04版,並且apt update, apt upgrade,把gcin更新到16.04適用的版本,而且順利無誤。

不知道從頭安裝和更新過去是否能視為相同情況。

參考資料


[2] 回覆: 裝了 ubuntu 16.04 lts 64位元版 一直無法輸入中文
[3] ubuntu Server 安裝 Unity 圖型界面

沒有留言:

張貼留言